experchange > ruby

Grimble (12-05-19, 06:29 PM)
Environment: ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-linux]
Just upgraded From Mageia 6 to Mageia 7 (in-situ, not fresh install)
A Ruby program that worked under Mageia 6 now refuses with error message:

`require': cannot load such file -- sequel (LoadError)

I have researched this error (pretty frequent on Stackoverflow!) but
can't see a solution that pertains.
From 'gem environment'

- GEM PATHS:
- /home/graeme/.gem/ruby/2.5.0
- /usr/share/gems
- /usr/local/share/gems
But it's there:

[graeme@bach Scripts]$ cd /usr/local/share/gems/gems
[graeme@bach gems]$ ls -l
total 20
drwxr-xr-x 5 root root 4096 Dec 1 18:14 bigdecimal-1.4.4/
drwxr-xr-x 5 root root 4096 Dec 1 18:12 mini_portile2-2.4.0/
drwxr-xr-x 6 root root 4096 Dec 1 18:14 nokogiri-1.10.5/
drwxr-xr-x 5 root root 4096 Dec 3 15:39 pg-1.1.4/
drwxr-xr-x 6 root root 4096 Dec 4 12:29 sequel-5.27.0/
Using the full path doesn't help either:

require '/usr/local/share/gems/gems/sequel'
cannot load such file -- /usr/local/share/gems/gems/sequel (LoadError)
Would appreciate some help please.
jasnow1 (12-06-19, 03:50 PM)
What ruby gem manager do you use?

What does "gem list sequel" return?

On Thursday, December 5, 2019 at 11:29:54 AM UTC-5, Grimble wrote:
[..]
Grimble (12-06-19, 05:50 PM)
On 06/12/2019 13:50, jasnow1 wrote:
> What ruby gem manager do you use?

gem -v
2.6.14
> What does "gem list sequel" return? gem list sequel


*** LOCAL GEMS ***

sequel (5.27.0, 5.12.0)
[..]
Similar Threads