experchange > lisp

Bigos (07-11-19, 01:38 AM)
I have tried to run this code



However I can not replicate the examples.

I do not know what has changed, but I can not run the examples from from
MKCL source or examples from ecl manual. Does anybody have any suggestions?

This is the proof I have tried:

CL-USER> (load
"/home/jacek/Programming/Lisp/mkclFFIexperiments/readme.lisp")
; Evaluation aborted on #<a SIMPLE-ERROR 140570980529472>.
CL-USER> (require 'asdf)
NIL
CL-USER> (require 'cmp)
NIL
CL-USER> (setf *load-verbose* nil)
NIL
CL-USER> (setf *compile-verbose* nil)
NIL
CL-USER> (setf c::*suppress-compiler-warnings* t)
; Evaluation aborted on #<a SIMPLE-ERROR 140570977044640>.
Pascal J. Bourguignon (07-11-19, 06:21 PM)
Bigos <ruby.object> writes:

[..]
> NIL
> CL-USER> (setf c::*suppress-compiler-warnings* t)
> ; Evaluation aborted on #<a SIMPLE-ERROR 140570977044640>.


I can't find the same file in a freshly cloned MCKL repo:

[pjb@despina org.macports:0 MKCL 584Gi]$ find . -name readme.lisp
../contrib/asdf/test/ecl-make-image/readme.lisp
../contrib/asdf/test/ecl-prebuilt-systems/readme.lisp
../contrib/asdf-3.1.7/test/ecl-make-image/readme.lisp
../contrib/asdf-3.1.7/test/ecl-prebuilt-systems/readme.lisp
../examples/ecl/asdf/readme.lisp
../examples/ecl/build/readme.lisp
Bigos (07-11-19, 08:59 PM)
On 11/07/2019 17:21, Pascal J. Bourguignon wrote:
> Bigos <ruby.object> writes:
> I can't find the same file in a freshly cloned MCKL repo:
> [pjb@despina org.macports:0 MKCL 584Gi]$ find . -name readme.lisp
> ./contrib/asdf/test/ecl-make-image/readme.lisp
> ./contrib/asdf/test/ecl-prebuilt-systems/readme.lisp
> ./contrib/asdf-3.1.7/test/ecl-make-image/readme.lisp
> ./contrib/asdf-3.1.7/test/ecl-prebuilt-systems/readme.lisp
> ./examples/ecl/asdf/readme.lisp
> ./examples/ecl/build/readme.lisp


Is your grep broken? Look at your output, second line from the bottom :-D
Bigos (07-12-19, 01:29 AM)
On 11/07/2019 00:38, Bigos wrote:
[..]
> NIL
> CL-USER> (setf c::*suppress-compiler-warnings* t)
> ; Evaluation aborted on #<a SIMPLE-ERROR 140570977044640>.


I have compiled ECL and had some success.
Bigos (07-12-19, 01:35 AM)
On 12/07/2019 00:29, Bigos wrote:
> On 11/07/2019 00:38, Bigos wrote:
> I have compiled ECL and had some success.


I tried again with MKCL and got an error.

CL-USER> (load "~/Programming/MKCL/examples/ecl/build/readme.lisp")
gives

Unknown keyword :SYSTEM-P
[Condition of type SI:SIMPLE-PROGRAM-ERROR]

Should I stick to ECL for now?
Bigos (07-12-19, 12:20 PM)
On 12/07/2019 00:35, Bigos wrote:
> On 12/07/2019 00:29, Bigos wrote:
> I tried again with MKCL and got an error.
> CL-USER> (load "~/Programming/MKCL/examples/ecl/build/readme.lisp")
> gives
> Unknown keyword :SYSTEM-P
>    [Condition of type SI:SIMPLE-PROGRAM-ERROR]
> Should I stick to ECL for now?


Hmm, There is no problem compiling MKCL on Windows. But I got stuck with
ECL. It's not as simple as I thought.
Bigos (07-13-19, 03:15 AM)
On 12/07/2019 11:20, Bigos wrote:
> On 12/07/2019 00:35, Bigos wrote:
> Hmm, There is no problem compiling MKCL on Windows. But I got stuck with
> ECL. It's not as simple as I thought.


I managed to find old binary installer of ecl



and had partial success trying ecl examples
Similar Threads