experchange > dataprotectionmanager

Eric Long (11-13-09, 01:43 AM)
When trying to create protection groups I get the following errors in DPM 2010:
Error 360: The operation failed due to a virtual disk service error
Error details: Unknown error (0x80042428)
Recommended action: Retry the operation.

I have rebooted, restarted Virtual Disk service and added a new drive to
storage pool. Have tried just local disks and with Hyper-V. Result is the
same in each case.

Now what should I try?
Praveen D [MSFT] (11-13-09, 10:11 AM)
From the website:
This error
is given by VDS as it is finding the disk as ReadOnly(0x80042428
VDS_E_MEDIA_WRITE_PROTECTED)

Below is simple sequence of commands clear the ReadOnly Attribute of a disk.
After that please retry the operation.

cmd> diskpart
Microsoft DiskPart version 6.0.6001
Copyright (C) 1999-2007 Microsoft Corporation.
On computer: PRAVEEND-LH
DISKPART> list disk
Disk ### Status Size Free Dyn Gpt
-------- ---------- ------- ------- --- ---
Disk 0 Online 49 GB 6144 KB
Disk 1 Online 29 GB 0 B *
Disk 2 Online 29 GB 0 B *
Disk 3 Online 29 GB 29 GB *
Disk 4 Online 29 GB 29 GB *
Disk 5 Online 105 GB 105 GB *
DISKPART> select disk 5
Disk 5 is now the selected disk.
DISKPART> detail disk
DELL PERC 6/i SCSI Disk Device
Disk ID: 7D95498A
Type : RAID
Bus : 1
Target : 5
LUN ID : 0
Read-only : Yes
Boot Disk : No
Pagefile Disk : No
Hibernation File Disk : No
Crashdump Disk : No
There are no volumes.
DISKPART> attribute disk clear readonly
Disk attributes cleared successfully.

Thanks,
Praveen D [MSFT]
This posting is provided “AS IS” with no warranties, and confers no rights

"Eric Long" <EricLong> wrote in message
news:ae74
[..]
Eric Long (11-14-09, 01:19 AM)
Good suggestion, but it's not in read only mode:
DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ------------- ------- ------- --- ---
Disk 0 Online 232 GB 0 B *
Disk 1 Online 232 GB 1024 KB *
Disk 2 Online 76 GB 3072 KB
Disk 3 Online 1863 GB 1862 GB * *
Disk 4 Online 372 GB 372 GB *

DISKPART> select disk 3

Disk 3 is now the selected disk.

DISKPART> detail disk

SATA ST32000542AS SCSI Disk Device
Disk ID: {BB008995-0D1E-45D8-AFD1-9D693BFF3FF7}
Type : RAID
Status : Online
Path : 0
Target : 0
LUN ID : 0
Location Path : PCIROOT(0)#PCI(1C03)#PCI(0000)#RAID(P00T00L00)
Current Read-only State : No
Read-only : No
Boot Disk : No
Pagefile Disk : No
Hibernation File Disk : No
Crashdump Disk : No
Clustered Disk : No

There are no volumes.

"Praveen D [MSFT]" wrote:
[..]
Praveen D [MSFT] (11-16-09, 09:12 AM)
Can you please try creating a volume using diskmgmt.msc. If you are able to
create the volume using can you please send us the DPM logs using tool
present at:


If volume creating is failing with diskmgmt.msc, You can try the following
options:
1. diskpart-> select disk $num -> clean -> convert dynamic -> convert basic
2. diskpart -> select disk $num -> clean all -> convert dynamic -> convert
basic(clean all is a really long running operation)
3. Using diskmgmt.msc convert dynamic to basic and basic to dynamic/basic to
dynamic and dynamic to basic.

If this one doesn’t help we need to collect the VDS logs. I’ll try to get
this info on how to collect the VDS logs and contact. Also as mentioned in
another thread can you make sure you don't have any issues with the disk
driver.

Thanks,
Praveen D
This posting is provided “AS IS” with no warranties, and confers no rights

"Eric Long" <EricLong> wrote in message
news:6ccf
[..]
Eric Long (11-17-09, 07:54 AM)
I am able to manually create volumes on that disk.

How do you want me to send the DPM logs? Is there a specific email address
to send to?

Also, there are a number of vbscrips and executables in the
MPSreports\dpm\bin folder. Which do I use?

"Praveen D [MSFT]" wrote:
[..]
Eric Long (11-17-09, 07:11 PM)
Updating to the latest RAID driver for my motherboard worked! Thanks for the
help.

"Eric Long" wrote:
[..]
souzemen (11-16-17, 01:13 PM)
after DISKPART> attribute disk clear readonly
Diskpart failed to clear disk attributes

after DISKPART>clean {all}
Disk Part has encountered an error: The request could not be performed because of an I/O device error.
See the System Event Log for more information
Similar Threads